summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-02-22 17:43:55 -0500
committerBrad King <brad.king@kitware.com>2022-02-22 17:50:06 -0500
commitd6b811fb8253ffa00bc36cba8b70b2b2f59eaf7c (patch)
treef19ce50e5f3fbad4e934cfa2b8a41342cc12d67f /CMakeLists.txt
parentd985c12fa47b5bf4ff1f64be460d18af5e839e5c (diff)
downloadcmake-d6b811fb8253ffa00bc36cba8b70b2b2f59eaf7c.tar.gz
Require CMake 3.13+ to configure CMake itself
In particular, guarantee that policy `CMP0077` has `NEW` behavior. This will be useful to hard-code options of third-party libraries without polluting our own cache.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 20389583da..547c32da86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
# Distributed under the OSI-approved BSD 3-Clause License. See accompanying
# file Copyright.txt or https://cmake.org/licensing for details.
-cmake_minimum_required(VERSION 3.1...3.22 FATAL_ERROR)
+cmake_minimum_required(VERSION 3.13...3.22 FATAL_ERROR)
set(CMAKE_USER_MAKE_RULES_OVERRIDE_C ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideC.cmake)
set(CMAKE_USER_MAKE_RULES_OVERRIDE_CXX ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideCXX.cmake)