summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2020-06-25 14:23:25 +0200
committerMarc Chevrier <marc.chevrier@gmail.com>2020-07-09 15:24:43 +0200
commite5798126fcfd08c7ca0f0f8d1fb627b04f655198 (patch)
tree59419db7f0c352ac662e20506acec74ee627be5c /CMakeLists.txt
parent4408f34cfe5edc76faa1ea974a0225316cfbc702 (diff)
downloadcmake-e5798126fcfd08c7ca0f0f8d1fb627b04f655198.tar.gz
STL Support: introduce dedicated configuration file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f62c666bd1..2d860d4a8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,6 +108,11 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
endif()
endif()
+# Inform STL library header wrappers whether to use system versions.
+configure_file(${CMake_SOURCE_DIR}/Utilities/std/cmSTL.hxx.in
+ ${CMake_BINARY_DIR}/Utilities/cmSTL.hxx
+ @ONLY)
+
# set the internal encoding of CMake to UTF-8
set(KWSYS_ENCODING_DEFAULT_CODEPAGE CP_UTF8)