summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-08-22 15:21:06 -0400
committerBrad King <brad.king@kitware.com>2019-08-23 11:12:07 -0400
commited294c1664cafe573c813f2a95ebec3159e0d21e (patch)
treeb345410fd29d1693a90837d7ea8fd59b1f96e161 /CMakeLists.txt
parent4b8a864d52fa7501af915b3f94dfbd55fe9065b8 (diff)
downloadcmake-ed294c1664cafe573c813f2a95ebec3159e0d21e.tar.gz
Add option to skip CMake tests that need network access
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3daebee016..d6e7278bd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -677,7 +677,7 @@ endif()
# to a cdash4simpletest database. In these cases, the CDash dashboards
# should be run first.
#
-if("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x")
+if("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x" AND NOT CMake_TEST_NO_NETWORK)
set(CMAKE_TESTS_CDASH_SERVER "http://open.cdash.org")
endif()