summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorErofeevK <erofeev.info@gmail.com>2018-04-16 02:48:31 -0400
committerBrad King <brad.king@kitware.com>2018-04-16 11:33:52 -0400
commitf5f72ff844a3130568dbc62517401c5727fcf9ec (patch)
treec152256724804e30c6995cb59de4278f46c99239 /CMakeLists.txt
parent61fd4c742013a7f9139db190f936703b656540ff (diff)
downloadcmake-f5f72ff844a3130568dbc62517401c5727fcf9ec.tar.gz
Explicitly require LibUV 1.10 or higher to build CMake
CMake 3.11 now uses `uv_translate_sys_error` introduced in LibUV 1.10.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66239595ef..3ab679ea9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -546,7 +546,7 @@ macro (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
# Build libuv library.
if(CMAKE_USE_SYSTEM_LIBUV)
- find_package(LibUV 1.0.0)
+ find_package(LibUV 1.10.0)
if(NOT LIBUV_FOUND)
message(FATAL_ERROR
"CMAKE_USE_SYSTEM_LIBUV is ON but a libuv is not found!")