summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-05-11 12:11:29 -0400
committerBrad King <brad.king@kitware.com>2020-05-11 12:13:25 -0400
commitf7a94cf282dabaa235f048e2c4e85080a4f84e61 (patch)
treea7379b9da7e3c764a22a11634d8b4c60f37b8be6 /CMakeLists.txt
parent615129f3ebd308abeaaee7f5f0689e7fc4616c28 (diff)
downloadcmake-f7a94cf282dabaa235f048e2c4e85080a4f84e61.tar.gz
XL: Install our Fortran 'cpp' helper script with execute permission
This script was added by commit 19f267c75e (XL: Add support for Ninja and XL Fortran, 2019-11-21, v3.17.0-rc1~368^2) but does not have a `.sh` extension so our existing install rules neglect to give it execute permission. Our test suite works on XL Fortran in the build tree but the script is broken without execute permission on installation. Fixes: #20695
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb7b9b7d6b..0d6a38c79f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -810,7 +810,7 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
PATTERN "*.sh*" PERMISSIONS OWNER_READ OWNER_EXECUTE OWNER_WRITE
GROUP_READ GROUP_EXECUTE
WORLD_READ WORLD_EXECUTE
- PATTERN "ExportImportList"
+ REGEX "/(ExportImportList|cpp)$"
PERMISSIONS OWNER_READ OWNER_EXECUTE OWNER_WRITE
GROUP_READ GROUP_EXECUTE
WORLD_READ WORLD_EXECUTE