summaryrefslogtreecommitdiff
path: root/Help/guide/tutorial/Step3/CMakeLists.txt
diff options
context:
space:
mode:
authorBetsy McPhail <betsy.mcphail@kitware.com>2019-07-01 20:58:32 -0400
committerBrad King <brad.king@kitware.com>2019-08-19 11:49:05 -0400
commit49ce4d6ff4e70026ab1da6da91d7965ef61863ab (patch)
treed519e2a2f16f1ebc0ae447e5b98860403f42bc39 /Help/guide/tutorial/Step3/CMakeLists.txt
parent82332f81bbb0609bf521d29c36b3ecf1566be892 (diff)
downloadcmake-49ce4d6ff4e70026ab1da6da91d7965ef61863ab.tar.gz
Tutorial: Improve Step 2
* Fix typo in #include * Remove CMakeLists file that users should create * Clarify which files users are expected to create * Highlight the importance of configuring TutorialConfig.h.in after the MY_MATH option has been set
Diffstat (limited to 'Help/guide/tutorial/Step3/CMakeLists.txt')
-rw-r--r--Help/guide/tutorial/Step3/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Help/guide/tutorial/Step3/CMakeLists.txt b/Help/guide/tutorial/Step3/CMakeLists.txt
index 4d7a6e7d20..1c128165fc 100644
--- a/Help/guide/tutorial/Step3/CMakeLists.txt
+++ b/Help/guide/tutorial/Step3/CMakeLists.txt
@@ -14,7 +14,7 @@ option(USE_MYMATH "Use tutorial provided math implementation" ON)
# to the source code
configure_file(TutorialConfig.h.in TutorialConfig.h)
-# add the MathFunctions library?
+# add the MathFunctions library
if(USE_MYMATH)
add_subdirectory(MathFunctions)
list(APPEND EXTRA_LIBS MathFunctions)
@@ -24,7 +24,7 @@ endif()
# add the executable
add_executable(Tutorial tutorial.cxx)
-target_link_libraries(Tutorial ${EXTRA_LIBS})
+target_link_libraries(Tutorial PUBLIC ${EXTRA_LIBS})
# add the binary tree to the search path for include files
# so that we will find TutorialConfig.h