summaryrefslogtreecommitdiff
path: root/Help/guide/tutorial/Step3/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Choisel <paul.choisel@kitware.com>2023-04-14 16:18:04 +0200
committerPaul Choisel <paul.choisel@kitware.com>2023-04-28 16:23:59 +0200
commitc6a426198a9ea204d6e5990467426a86bd07b25c (patch)
treef45c93c44a5129b0c72355be94b78606d713d754 /Help/guide/tutorial/Step3/CMakeLists.txt
parent6c11f7e4a8805189835c04a398864f96081b3183 (diff)
downloadcmake-c6a426198a9ea204d6e5990467426a86bd07b25c.tar.gz
Tutorial: Move Step4-Ex1 to Step3-Ex2
During the training, we talk about INTERFACE libraries just before Step3 so it makes more sense to do the exercise related to them in Step3
Diffstat (limited to 'Help/guide/tutorial/Step3/CMakeLists.txt')
-rw-r--r--Help/guide/tutorial/Step3/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Help/guide/tutorial/Step3/CMakeLists.txt b/Help/guide/tutorial/Step3/CMakeLists.txt
index f051826a7d..ac3e9f1ed7 100644
--- a/Help/guide/tutorial/Step3/CMakeLists.txt
+++ b/Help/guide/tutorial/Step3/CMakeLists.txt
@@ -3,6 +3,12 @@ cmake_minimum_required(VERSION 3.10)
# set the project name and version
project(Tutorial VERSION 1.0)
+# TODO 4: Replace the following code by:
+# * Creating an interface library called tutorial_compiler_flags
+# Hint: use add_library() with the INTERFACE signature
+# * Add compiler feature cxx_std_11 to tutorial_compiler_flags
+# Hint: Use target_compile_features()
+
# specify the C++ standard
set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD_REQUIRED True)
@@ -20,6 +26,8 @@ list(APPEND EXTRA_INCLUDES "${PROJECT_SOURCE_DIR}/MathFunctions")
# add the executable
add_executable(Tutorial tutorial.cxx)
+# TODO 5: Link Tutorial to tutorial_compiler_flags
+
target_link_libraries(Tutorial PUBLIC MathFunctions)
# TODO 3: Remove use of EXTRA_INCLUDES