summaryrefslogtreecommitdiff
path: root/Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Choisel <paul.choisel@kitware.com>2023-04-14 16:18:04 +0200
committerPaul Choisel <paul.choisel@kitware.com>2023-04-28 16:23:59 +0200
commitc6a426198a9ea204d6e5990467426a86bd07b25c (patch)
treef45c93c44a5129b0c72355be94b78606d713d754 /Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt
parent6c11f7e4a8805189835c04a398864f96081b3183 (diff)
downloadcmake-c6a426198a9ea204d6e5990467426a86bd07b25c.tar.gz
Tutorial: Move Step4-Ex1 to Step3-Ex2
During the training, we talk about INTERFACE libraries just before Step3 so it makes more sense to do the exercise related to them in Step3
Diffstat (limited to 'Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt')
-rw-r--r--Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt b/Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt
index ffab4f0a80..48561eb23b 100644
--- a/Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt
+++ b/Help/guide/tutorial/Step4/MathFunctions/CMakeLists.txt
@@ -17,9 +17,10 @@ if (USE_MYMATH)
mysqrt.cxx
)
- # TODO 4: Link to tutorial_compiler_flags
-
+ # link our compiler flags interface library
+ target_link_libraries(SqrtLibrary PUBLIC tutorial_compiler_flags)
target_link_libraries(MathFunctions PUBLIC SqrtLibrary)
endif()
-# TODO 3: Link to tutorial_compiler_flags
+# link our compiler flags interface library
+target_link_libraries(MathFunctions PUBLIC tutorial_compiler_flags)