summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAmitha Perera <perera@cs.rpi.edu>2002-05-01 14:00:21 -0400
committerAmitha Perera <perera@cs.rpi.edu>2002-05-01 14:00:21 -0400
commit1f8df8585ef36aa980d13a0cb6646de399bceff9 (patch)
tree3106ab0d6e942aa15c783425316235c75c790e8b /Source/CMakeLists.txt
parentd53458de9ac298344a87d6703de78991d6770832 (diff)
downloadcmake-1f8df8585ef36aa980d13a0cb6646de399bceff9.tar.gz
ENH: Add library dependency analysis.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index b9f3b56844..0a27df06bf 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -162,6 +162,14 @@ IF(BUILD_TESTING)
${CMake_BINARY_DIR}/Tests/Wrapping/bin
TestDriverTest subdir/test3)
+ ADD_TEST(dependency ${CMake_BINARY_DIR}/Source/cmaketest
+ ${CMake_SOURCE_DIR}/Tests/Dependency
+ ${CMake_BINARY_DIR}/Tests/Dependency
+ exec
+ ${CMake_BINARY_DIR}/Tests/Dependency/Exec
+ Dependency)
+
+ ENDIF (DART_ROOT)
ENDIF(BUILD_TESTING)