summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-03-09 11:06:58 -0500
committerBrad King <brad.king@kitware.com>2023-03-13 11:49:56 -0400
commit9504cef8c4d505f4f9fa66cbd485a2ac8b24ab72 (patch)
tree42c582cf5ecfac82823f65e501ad80d1684f4167 /Source/CMakeLists.txt
parent60ef076bacca9a265ab4ab68032933c464e84a66 (diff)
downloadcmake-9504cef8c4d505f4f9fa66cbd485a2ac8b24ab72.tar.gz
Tests: Allow RunCMake.MaxRecursionDepth to test public-facing default limit
Previously we compiled in a smaller default limit during nightly testing and CI builds, so we were not testing the same default limit that end-users will see. Instead, set the limit during testing using an environment variable so that we can unset it when testing the default limit in `RunCMake.MaxRecursionDepth`.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 163dab3beb..a25329ce62 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -12,9 +12,7 @@ endif()
include(CheckIncludeFile)
if(NOT CMake_DEFAULT_RECURSION_LIMIT)
- if(DEFINED ENV{DASHBOARD_TEST_FROM_CTEST})
- set(CMake_DEFAULT_RECURSION_LIMIT 100)
- elseif(MINGW OR MSYS)
+ if(MINGW OR MSYS)
set(CMake_DEFAULT_RECURSION_LIMIT 400)
elseif(WIN32 AND CMAKE_C_COMPILER_ARCHITECTURE_ID STREQUAL "ARM64")
set(CMake_DEFAULT_RECURSION_LIMIT 400)