summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2017-11-16 09:59:03 +0100
committerSebastian Holtermann <sebholt@xwmw.org>2017-11-19 12:51:30 +0100
commitb2a0b549bb9fea678517a52caf333eae009901dd (patch)
treea19e2b6ed59897a505f5e2b8caaddeed3de4dcf8 /Source/CMakeLists.txt
parent85ae0ba796c26b9ba2f7025e267d3f438db388c6 (diff)
downloadcmake-b2a0b549bb9fea678517a52caf333eae009901dd.tar.gz
Autogen: Introduce standalone RCC generator class
Introduces the standalone RCC generator class `cmQtAutoGeneratorRcc`. Every instance of `cmQtAutoGeneratorRcc` class handles the `rcc` invocation for a single `.qrc` file. The class will be used in the future to allow parallel `.qrc` file processing by calling `cmake -E cmake_autorcc <INFO_FILE> <CONFIG>`.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 54e50636af..fd0219604d 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -316,6 +316,8 @@ set(SRCS
cmQtAutoGeneratorInitializer.h
cmQtAutoGenerators.cxx
cmQtAutoGenerators.h
+ cmQtAutoGeneratorRcc.cxx
+ cmQtAutoGeneratorRcc.h
cmRST.cxx
cmRST.h
cmScriptGenerator.h