summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-04-16 17:58:02 -0400
committerKyle Edwards <kyle.edwards@kitware.com>2019-04-25 12:14:00 -0400
commitc74698cb75b9923517f7f87eacf04ca0eefc8e72 (patch)
tree890d752d404fe359c616ccf8bfa33e426fe46327 /Source/CMakeLists.txt
parent8cfd25db711c22f9478e565a496145577df24d77 (diff)
downloadcmake-c74698cb75b9923517f7f87eacf04ca0eefc8e72.tar.gz
cmUVStreambuf: Add std::streambuf implementation for uv_stream_t
This will allow std::istream/std::ostream-based interaction with processes spawned by libuv.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 6fa046c258..01c6cd7077 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -388,6 +388,7 @@ set(SRCS
cmUuid.cxx
cmUVHandlePtr.cxx
cmUVHandlePtr.h
+ cmUVStreambuf.h
cmUVSignalHackRAII.h
cmVariableWatch.cxx
cmVariableWatch.h