summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2015-07-03 12:58:22 +0300
committerBrad King <brad.king@kitware.com>2015-07-07 09:16:40 -0400
commitc823f04e0cbc4753cc5b6d5c9f45b9f015a12568 (patch)
tree4edbd2e75f2c40e2884930e203dffa170864dcb6 /Source/CMakeLists.txt
parent7383e4d722809e2460bd4e87ea7fdbef5f64c303 (diff)
downloadcmake-c823f04e0cbc4753cc5b6d5c9f45b9f015a12568.tar.gz
CMake: New option CMake_INSTALL_COMPONENTS
By default is OFF. Now it's used with CPack IFW himself installer.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 83d3090eb8..aa3f675e09 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -743,7 +743,8 @@ if(APPLE)
endif()
foreach(_tool ${_tools})
- install(TARGETS ${_tool} DESTINATION bin COMPONENT ${_tool})
+ CMake_OPTIONAL_COMPONENT(${_tool})
+ install(TARGETS ${_tool} DESTINATION bin ${COMPONENT})
endforeach()
install(FILES cmCPluginAPI.h DESTINATION ${CMAKE_DATA_DIR}/include)