summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorWouter Klouwen <wouter.klouwen@youview.com>2017-12-12 21:59:43 +0000
committerBrad King <brad.king@kitware.com>2018-01-23 10:05:12 -0500
commitff62b00522d1ddaeb88be241ab4a022f935b5c00 (patch)
tree5144559ff41c2374fd01637b0326fb18eed2c1eb /Source/CMakeLists.txt
parent695951bc46fa4bc4eaf686c4ee6dce24c579bc45 (diff)
downloadcmake-ff62b00522d1ddaeb88be241ab4a022f935b5c00.tar.gz
CTest: add safe conversion from cmDuration to integer types
A problem area by recent refactoring of time to std::chrono has been the unsafe conversion from duration<double> to std::chrono::seconds, which is of an unspecified integer type. This commit adds a template function that for a given type provides a safe conversion, effectively clamping a duration<double> into what fits safely in that type. A specialisation for int and unsigned int are provided. It changes the protential problem areas to use this safe function.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index cd1287cbed..da5dc609a6 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -602,6 +602,9 @@ set(SRCS
cm_codecvt.hxx
cm_codecvt.cxx
cm_thread.hxx
+
+ cmDuration.h
+ cmDuration.cxx
)
SET_PROPERTY(SOURCE cmProcessOutput.cxx APPEND PROPERTY COMPILE_DEFINITIONS