summaryrefslogtreecommitdiff
path: root/Tests/BuildDepends/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2007-05-16 07:55:00 -0400
committerAndy Cedilnik <andy.cedilnik@kitware.com>2007-05-16 07:55:00 -0400
commit9338803697da3623a61631809898af2334e38c48 (patch)
tree5da13c46c5a764f405435826e9d465111ab5b9b6 /Tests/BuildDepends/CMakeLists.txt
parent4b33244ea58870ee864e7f5ce4a801d0dcb2cd3c (diff)
downloadcmake-9338803697da3623a61631809898af2334e38c48.tar.gz
BUG: fix test for hp move to c++ to avoid ansi issues and produce a message if the compile fails, (really checked in by Bill H.)
Diffstat (limited to 'Tests/BuildDepends/CMakeLists.txt')
-rw-r--r--Tests/BuildDepends/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/Tests/BuildDepends/CMakeLists.txt b/Tests/BuildDepends/CMakeLists.txt
index ed2f10c126..80793bc6e1 100644
--- a/Tests/BuildDepends/CMakeLists.txt
+++ b/Tests/BuildDepends/CMakeLists.txt
@@ -6,13 +6,17 @@
# and source files for the test project.
project(BuildDepends)
make_directory(${BuildDepends_BINARY_DIR}/Project)
-write_file(${BuildDepends_BINARY_DIR}/Project/foo.c
+write_file(${BuildDepends_BINARY_DIR}/Project/foo.cxx
"const char* foo() { return \"foo\";}" )
try_compile(RESULT
${BuildDepends_BINARY_DIR}/Project
${BuildDepends_SOURCE_DIR}/Project
testRebuild
OUTPUT_VARIABLE OUTPUT)
+if(NOT RESULT)
+ message(SEND_ERROR "Could not build test project: ${OUTPUT}")
+endif(NOT RESULT)
+
set(bar ${BuildDepends_BINARY_DIR}/Project/bar${CMAKE_EXECUTABLE_SUFFIX})
message("${BuildDepends_BINARY_DIR}/Project/Debug/bar${CMAKE_EXECUTABLE_SUFFIX}")
if(EXISTS
@@ -32,7 +36,7 @@ else("${out}" STREQUAL "foo ")
message(SEND_ERROR "Program did not rebuild with changed file: ${out}")
endif("${out}" STREQUAL "foo ")
-write_file(${BuildDepends_BINARY_DIR}/Project/foo.c
+write_file(${BuildDepends_BINARY_DIR}/Project/foo.cxx
"const char* foo() { return \"foo changed\";}" )
try_compile(RESULT
${BuildDepends_BINARY_DIR}/Project
@@ -40,6 +44,9 @@ try_compile(RESULT
testRebuild
OUTPUT_VARIABLE OUTPUT)
+if(NOT RESULT)
+ message(SEND_ERROR "Could not build test project: ${OUTPUT}")
+endif(NOT RESULT)
if(EXISTS
"${BuildDepends_BINARY_DIR}/Project/Debug/bar${CMAKE_EXECUTABLE_SUFFIX}" )
message("found debug")