summaryrefslogtreecommitdiff
path: root/Tests/BundleGeneratorTest/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-01-21 13:39:22 -0500
committerDavid Cole <david.cole@kitware.com>2009-01-21 13:39:22 -0500
commit36c228814b18ef115a1a72cac4f103691f249569 (patch)
tree8bcec68f08b0480ce329df9e0e28bf51b81af6ff /Tests/BundleGeneratorTest/CMakeLists.txt
parent88a499c54c699c0893aee2736f22afbb457fbb41 (diff)
downloadcmake-36c228814b18ef115a1a72cac4f103691f249569.tar.gz
BUG: Fix issue #7523: Analyze output of 'hdiutil attach' to get the name of the volume that was mounted. Eliminates the need to use the -mountpoint arg of hdiutil which has a silly 90 character limit on the name of the mount point. Also add a custom volume icon to the BundleGeneratorTest to cover this code.
Diffstat (limited to 'Tests/BundleGeneratorTest/CMakeLists.txt')
-rw-r--r--Tests/BundleGeneratorTest/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/Tests/BundleGeneratorTest/CMakeLists.txt b/Tests/BundleGeneratorTest/CMakeLists.txt
index e671d40b35..e1fc2c1d40 100644
--- a/Tests/BundleGeneratorTest/CMakeLists.txt
+++ b/Tests/BundleGeneratorTest/CMakeLists.txt
@@ -18,7 +18,16 @@ SET(CPACK_BUNDLE_NAME "BundleGeneratorTest")
SET(CPACK_BUNDLE_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.plist")
SET(CPACK_BUNDLE_STARTUP_COMMAND "${CMAKE_CURRENT_SOURCE_DIR}/StartupCommand")
SET(CPACK_PACKAGE_DESCRIPTION "Project for testing OSX bundle generation")
+
+# The custom volume icon is a copy of the normal Mac OSX volume icon, but
+# on a white background. This is to differentiate it from the normal one
+# so that you can verify that the custom icon is being used by doing a
+# visual inspection of the mounted volume... This was added when fixing
+# issue #7523...
+#
+SET(CPACK_PACKAGE_ICON "${CMAKE_CURRENT_SOURCE_DIR}/CustomVolumeIcon.icns")
+
SET(CPACK_PACKAGE_NAME "BundleGeneratorTest")
SET(CPACK_PACKAGE_VERSION "0.1")
-INCLUDE(CPack)
+INCLUDE(CPack)