summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-05-05 16:43:33 +0000
committerKitware Robot <kwrobot@kitware.com>2023-05-05 12:43:50 -0400
commit250f66acfea5f2842f1bef6bc8ee2d724dc8569e (patch)
tree9595b66bb179652babf203d54d1e7332c1a9d56c /Tests/CMakeLists.txt
parent5924630e6d4a383ef76412a6f560fbe852837e50 (diff)
parent0a5aeaf302369ab62f89ab35b0f0fb690f71c05a (diff)
downloadcmake-250f66acfea5f2842f1bef6bc8ee2d724dc8569e.tar.gz
Merge topic 'ctest-timeout-zero'
0a5aeaf302 cmCTestRunTest: Consolidate test timeout selection logic 426e38cc10 cmCTestRunTest: Adopt decision for starting cmProcess timer 59336b29bd cmCTestRunTest: Remove unnecessary arguments to ForkProcess 07b5087ba7 Help: Document meaning of TIMEOUT test property with value 0 3edf7fbb41 ctest: Fix TIMEOUT test property with value 0 with --timeout flag 39a20a56dd Tests: Move `CTestTestZeroTimeout` into `RunCMake.CTestTimeout` cd4038fe94 cmCTestTestHandler: Use in-class initialization of properties and results Acked-by: Kitware Robot <kwrobot@kitware.com> Acked-by: buildbot <buildbot@kitware.com> Merge-request: !8455
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index e3b5ec41d8..2fa962eeec 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -3192,17 +3192,6 @@ if(BUILD_TESTING)
WORKING_DIRECTORY ${CMake_BINARY_DIR}/Tests/CTestTestTimeout)
configure_file(
- "${CMake_SOURCE_DIR}/Tests/CTestTestZeroTimeout/test.cmake.in"
- "${CMake_BINARY_DIR}/Tests/CTestTestZeroTimeout/test.cmake"
- @ONLY ESCAPE_QUOTES)
- add_test(CTestTestZeroTimeout ${CMAKE_CTEST_COMMAND}
- -S "${CMake_BINARY_DIR}/Tests/CTestTestZeroTimeout/test.cmake" -V
- --output-log
- "${CMake_BINARY_DIR}/Tests/CTestTestZeroTimeout/testOutput.log")
- set_tests_properties(CTestTestZeroTimeout PROPERTIES
- FAIL_REGULAR_EXPRESSION "\\*\\*\\*Timeout")
-
- configure_file(
"${CMake_SOURCE_DIR}/Tests/CTestTestDepends/test.cmake.in"
"${CMake_BINARY_DIR}/Tests/CTestTestDepends/test.cmake"
@ONLY ESCAPE_QUOTES)