summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-02-08 08:16:48 -0500
committerBrad King <brad.king@kitware.com>2022-02-08 08:17:39 -0500
commit7b23fd6c1b91e32e20564864114ffd5b3732032a (patch)
treef240289375b1149d555f3ba46f198ed651d4a1c5 /Tests/CMakeLists.txt
parent7cf5355d5e3efeac7cd421fa5ac8f029ccf408d7 (diff)
downloadcmake-7b23fd6c1b91e32e20564864114ffd5b3732032a.tar.gz
Tests: Run CTest.UpdateBZR tests only if explicitly enabled
These tests have not been automatically enabled on current versions of `bzr` in a long time. The recent change to drop the `xmlplugins` heuristic caused the tests to start running on some machines, but they do not work everywhere. Disable the tests again pending further investigation.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 59cbbd9394..8ebe5ed270 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2603,15 +2603,9 @@ if(BUILD_TESTING)
endif()
# Test CTest Update with BZR
- if(NOT DEFINED CMake_TEST_CTestUpdate_BZR OR CMake_TEST_CTestUpdate_BZR)
+ if(CMake_TEST_CTestUpdate_BZR)
find_program(BZR_EXECUTABLE NAMES bzr)
mark_as_advanced(BZR_EXECUTABLE)
- endif()
- if(NOT DEFINED CMake_TEST_CTestUpdate_BZR AND BZR_EXECUTABLE
- AND (UNIX OR NOT "${BZR_EXECUTABLE}" MATCHES "cygwin"))
- set(CMake_TEST_CTestUpdate_BZR 1)
- endif()
- if(CMake_TEST_CTestUpdate_BZR)
if(NOT BZR_EXECUTABLE)
message(FATAL_ERROR "CMake_TEST_CTestUpdate_BZR enabled but BZR_EXECUTABLE is not found.")
endif()