summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-11-27 10:59:20 -0500
committerKyle Edwards <kyle.edwards@kitware.com>2019-12-13 10:52:07 -0500
commite0478cc64623fbfcb7dcd748f27b94cc8473fa1a (patch)
treefa28877d7db948f5aee23a9dbe0bc042d562150b /Tests/CMakeLists.txt
parent5a8a9f72293ab1b3fd768ff40e5fb1f07cdb7dd2 (diff)
downloadcmake-e0478cc64623fbfcb7dcd748f27b94cc8473fa1a.tar.gz
Tests: Add test for Multi-Configuration Ninja generator
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 7dbfeca368..59f5c733ae 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -211,6 +211,13 @@ if(BUILD_TESTING)
#---------------------------------------------------------------------------
# Add tests below here.
+ if(NOT DEFINED CMake_TEST_Qt5)
+ set(CMake_TEST_Qt5 1)
+ endif()
+ if(CMake_TEST_Qt5)
+ find_package(Qt5Widgets QUIET NO_MODULE)
+ endif()
+
if(NOT CMake_TEST_EXTERNAL_CMAKE)
add_subdirectory(CMakeLib)
@@ -1332,12 +1339,6 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/QtAutomocNoQt")
- if(NOT DEFINED CMake_TEST_Qt5)
- set(CMake_TEST_Qt5 1)
- endif()
- if(CMake_TEST_Qt5)
- find_package(Qt5Widgets QUIET NO_MODULE)
- endif()
if(CMake_TEST_Qt5 AND Qt5Widgets_FOUND)
add_subdirectory(Qt5Autogen)
endif()