summaryrefslogtreecommitdiff
path: root/Tests/CompileFeatures/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2015-01-03 15:18:39 +0100
committerStephen Kelly <steveire@gmail.com>2015-01-03 15:18:39 +0100
commit6296192defaaaa4c18b1821614c20b95ad94f806 (patch)
tree3a17715ba85d68da9ffea1aec27857a9b21a3d6c /Tests/CompileFeatures/CMakeLists.txt
parentc13656e7173a517961349a5fe20ce0f727d37568 (diff)
downloadcmake-6296192defaaaa4c18b1821614c20b95ad94f806.tar.gz
Features: Add a comment explaining part of test.
Diffstat (limited to 'Tests/CompileFeatures/CMakeLists.txt')
-rw-r--r--Tests/CompileFeatures/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CompileFeatures/CMakeLists.txt b/Tests/CompileFeatures/CMakeLists.txt
index 832f68b000..834ac7cc04 100644
--- a/Tests/CompileFeatures/CMakeLists.txt
+++ b/Tests/CompileFeatures/CMakeLists.txt
@@ -33,6 +33,8 @@ endforeach()
if (CMAKE_CXX_COMPILER_ID STREQUAL GNU
AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.8)
+ # The cxx_alignof feature happens to work (for *this* testcase) with
+ # GNU 4.7, but it is first documented as available with GNU 4.8.
list(REMOVE_ITEM CXX_non_features
cxx_alignof
)