summaryrefslogtreecommitdiff
path: root/Tests/Cuda/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <rmaynard@nvidia.com>2021-06-21 13:16:29 -0400
committerRobert Maynard <rmaynard@nvidia.com>2021-06-25 13:39:50 -0400
commita3cafa4237930d1ec1bcbdddc8a9c592e32458ca (patch)
tree33b38924f7edb95ccb18e054be5d757cce179ff5 /Tests/Cuda/CMakeLists.txt
parent66488d4eb31d372d8e06ce78e5f49a7cc43974ee (diff)
downloadcmake-a3cafa4237930d1ec1bcbdddc8a9c592e32458ca.tar.gz
compile_features: Ignore features that map to languages that aren't enabled
Remove the Cuda/ConsumeCompileFeatures test as it only existed to validate that using `cxx_std_XY` would cause the paired language (CUDA) to also build in mode XY.
Diffstat (limited to 'Tests/Cuda/CMakeLists.txt')
-rw-r--r--Tests/Cuda/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Tests/Cuda/CMakeLists.txt b/Tests/Cuda/CMakeLists.txt
index be5ccac509..669c412dff 100644
--- a/Tests/Cuda/CMakeLists.txt
+++ b/Tests/Cuda/CMakeLists.txt
@@ -4,7 +4,6 @@ macro (add_cuda_test_macro name)
PROPERTY LABELS "CUDA")
endmacro ()
-add_cuda_test_macro(Cuda.ConsumeCompileFeatures CudaConsumeCompileFeatures)
add_cuda_test_macro(Cuda.CXXStandardSetTwice CXXStandardSetTwice)
add_cuda_test_macro(Cuda.ObjectLibrary CudaObjectLibrary)
add_cuda_test_macro(Cuda.MixedStandardLevels1 MixedStandardLevels1)