summaryrefslogtreecommitdiff
path: root/Tests/Dependency/CMakeLists.txt
diff options
context:
space:
mode:
authorAmitha Perera <perera@cs.rpi.edu>2002-05-01 16:24:47 -0400
committerAmitha Perera <perera@cs.rpi.edu>2002-05-01 16:24:47 -0400
commit36f80fe6c8f7593462c450789b01f4eb37792996 (patch)
tree4c7a81e81780aa96ad9b485269e5af743bf785e2 /Tests/Dependency/CMakeLists.txt
parent1f8df8585ef36aa980d13a0cb6646de399bceff9 (diff)
downloadcmake-36f80fe6c8f7593462c450789b01f4eb37792996.tar.gz
ENH: Make the LinkLibraries command contribute dependencies towards AddLibraries.
Diffstat (limited to 'Tests/Dependency/CMakeLists.txt')
-rw-r--r--Tests/Dependency/CMakeLists.txt21
1 files changed, 14 insertions, 7 deletions
diff --git a/Tests/Dependency/CMakeLists.txt b/Tests/Dependency/CMakeLists.txt
index 81365d1750..508fe0171e 100644
--- a/Tests/Dependency/CMakeLists.txt
+++ b/Tests/Dependency/CMakeLists.txt
@@ -15,11 +15,13 @@ SET( CMAKE_ANALYZE_LIB_DEPENDS "ON" )
# ^ |
# | |
# One <------ Four -----> Two <----- Five <---+
-# |
-# ^ ^ |
-# | | |
-# +--------- Three <-------+
-#
+# |
+# ^ ^ ^ | ^ ^ ^
+# | | +-----+ | | | +----+
+# | | | | | | |
+# +--------- Three <------+ +------- SixA SixB
+# | |
+# +-----------------------+
# NoDepA:
# NoDepB: NoDepA
# NoDepC: NoDepA
@@ -28,11 +30,16 @@ SET( CMAKE_ANALYZE_LIB_DEPENDS "ON" )
# Three: One Four
# Four: One Two A
# Five: Two
-# Exec: NoDepB NoDepC Five
+# SixA: Two Five
+# SixB: Four Five
+# Exec: NoDepB NoDepC SixA SixB
#
# The libraries One,...,Five have their dependencies explicitly
# encoded. The libraries NoDepA,...,NoDepC do not.
+#
+# Although SixB does not depend on Two, there is a dependency listed
+# in the corresponding CMakeLists.txt just because of commands used.
SUBDIRS( NoDepA NoDepB NoDepC )
-SUBDIRS( One Two Three Four Five )
+SUBDIRS( One Two Three Four Five Six )
SUBDIRS( Exec )