summaryrefslogtreecommitdiff
path: root/Tests/Dependency/CMakeLists.txt
diff options
context:
space:
mode:
authorKitware Robot <kwrobot@kitware.com>2012-08-13 13:47:32 -0400
committerBrad King <brad.king@kitware.com>2012-08-13 14:19:16 -0400
commit77543bde41b0e52c3959016698b529835945d62d (patch)
treeff63e5fbec326c4a5d821e7496c6d2cb52f75b92 /Tests/Dependency/CMakeLists.txt
parent7bbaa4283de26864b2e55e819db0884771585467 (diff)
downloadcmake-77543bde41b0e52c3959016698b529835945d62d.tar.gz
Convert CMake-language commands to lower case
Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code: cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done >convert.sed && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' '*CMakeLists.txt' | egrep -z -v '^(Utilities/cm|Source/kwsys/)' | xargs -0 sed -i -f convert.sed && rm convert.sed
Diffstat (limited to 'Tests/Dependency/CMakeLists.txt')
-rw-r--r--Tests/Dependency/CMakeLists.txt40
1 files changed, 20 insertions, 20 deletions
diff --git a/Tests/Dependency/CMakeLists.txt b/Tests/Dependency/CMakeLists.txt
index 86e128f58e..ef4204803a 100644
--- a/Tests/Dependency/CMakeLists.txt
+++ b/Tests/Dependency/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required (VERSION 2.6)
-PROJECT( Dependency )
+project( Dependency )
# to test directories with only one character One was changed to 1
# There is one executable that depends on eight libraries. The
@@ -29,25 +29,25 @@ PROJECT( Dependency )
# Although SixB does not depend on Two, there is a dependency listed
# in the corresponding CMakeLists.txt just because of commands used.
-ADD_SUBDIRECTORY(NoDepA)
-ADD_SUBDIRECTORY(NoDepB)
-ADD_SUBDIRECTORY(NoDepC)
-ADD_SUBDIRECTORY(1)
-ADD_SUBDIRECTORY(Two)
-ADD_SUBDIRECTORY(Three)
-ADD_SUBDIRECTORY(Four)
-ADD_SUBDIRECTORY(Five)
-ADD_SUBDIRECTORY(Six)
-ADD_SUBDIRECTORY(Seven)
-ADD_SUBDIRECTORY(Eight)
-ADD_SUBDIRECTORY(Exec)
-ADD_SUBDIRECTORY(Exec2)
-ADD_SUBDIRECTORY(Exec3)
-ADD_SUBDIRECTORY(Exec4)
+add_subdirectory(NoDepA)
+add_subdirectory(NoDepB)
+add_subdirectory(NoDepC)
+add_subdirectory(1)
+add_subdirectory(Two)
+add_subdirectory(Three)
+add_subdirectory(Four)
+add_subdirectory(Five)
+add_subdirectory(Six)
+add_subdirectory(Seven)
+add_subdirectory(Eight)
+add_subdirectory(Exec)
+add_subdirectory(Exec2)
+add_subdirectory(Exec3)
+add_subdirectory(Exec4)
# Specific cases added to test fixes to problems found in real
# projects.
-ADD_SUBDIRECTORY(Case1)
-ADD_SUBDIRECTORY(Case2)
-ADD_SUBDIRECTORY(Case3)
-ADD_SUBDIRECTORY(Case4)
+add_subdirectory(Case1)
+add_subdirectory(Case2)
+add_subdirectory(Case3)
+add_subdirectory(Case4)