summaryrefslogtreecommitdiff
path: root/Tests/ExternalProject/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2010-02-17 16:21:41 -0500
committerDavid Cole <david.cole@kitware.com>2010-02-17 16:21:41 -0500
commitb39fe9407e37dfdefa0652d30a278eec75a7107b (patch)
treead6024d33ec0783b280572759bbc6cb77abec681 /Tests/ExternalProject/CMakeLists.txt
parent1e43973741819dd4ddb1df79636b6001b26e3613 (diff)
downloadcmake-b39fe9407e37dfdefa0652d30a278eec75a7107b.tar.gz
Fix problem with ExternalProject test in in-source builds.
Diffstat (limited to 'Tests/ExternalProject/CMakeLists.txt')
-rw-r--r--Tests/ExternalProject/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/ExternalProject/CMakeLists.txt b/Tests/ExternalProject/CMakeLists.txt
index e0d8c2ca81..f02f2f76d2 100644
--- a/Tests/ExternalProject/CMakeLists.txt
+++ b/Tests/ExternalProject/CMakeLists.txt
@@ -24,6 +24,17 @@ if(NOT DEFINED can_build_tutorial_step5)
set(can_build_tutorial_step5 0)
endif()
endif()
+
+ # The ExternalProject builds of Tutorial Step5 cannot be built
+ # correctly 2nd and later times in an in-source build...
+ # (because the CMakeCache.txt from the real in-source build of
+ # the Tests/Tutorial/Step5 directory gets copied when we do
+ # the "source directory copy" step... but it still refers to
+ # its original path which yields a configure error.) So:
+ #
+ if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
+ set(can_build_tutorial_step5 0)
+ endif()
endif()
message(STATUS "can_build_tutorial_step5='${can_build_tutorial_step5}'")