summaryrefslogtreecommitdiff
path: root/Tests/FindBoost/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2019-04-15 22:19:03 +0200
committerBrad King <brad.king@kitware.com>2019-04-16 13:31:27 -0400
commit0b54f72e940503adfbd978d7f1dedc3da4799f52 (patch)
tree6e439c912466fbb17c094bdbd2c1312ca07f39a9 /Tests/FindBoost/CMakeLists.txt
parent5e98111643e22ad515afa2bf48a92573b6987115 (diff)
downloadcmake-0b54f72e940503adfbd978d7f1dedc3da4799f52.tar.gz
FindBoost: Fix detection with version suffixes on Gentoo
The Gentoo case added by commit 1673923c30 (FindBoost: Add support for Boost 1.67 with Python version suffixes, 2018-03-18, v3.11.0~3^2) left out the `.` version component separator and instead duplicated the RPM case. Add the missing `.` now. Fixes: #18743
Diffstat (limited to 'Tests/FindBoost/CMakeLists.txt')
-rw-r--r--Tests/FindBoost/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/FindBoost/CMakeLists.txt b/Tests/FindBoost/CMakeLists.txt
index 17a8ec7009..58d795ba44 100644
--- a/Tests/FindBoost/CMakeLists.txt
+++ b/Tests/FindBoost/CMakeLists.txt
@@ -33,3 +33,16 @@ add_test(NAME FindBoost.TestHeaders COMMAND
--build-options ${build_options}
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)
+
+if (CMake_TEST_FindBoost_Python)
+ add_test(NAME FindBoost.TestPython COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindBoost/TestPython"
+ "${CMake_BINARY_DIR}/Tests/FindBoost/TestPython"
+ ${build_generator_args}
+ --build-project TestFindBoostPython
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )
+endif ()