summaryrefslogtreecommitdiff
path: root/Tests/FindPython/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2019-04-01 11:19:54 +0200
committerMarc Chevrier <marc.chevrier@gmail.com>2019-04-03 09:16:17 +0200
commit8a2f62cc18ece0ebfed0ff6abf53d419d43d2fa1 (patch)
tree465c79b4ce0f366fe40a00e1be9e965f3c04af4d /Tests/FindPython/CMakeLists.txt
parent5ad73b608d4fc7cc6b30017159b800802a503b0c (diff)
downloadcmake-8a2f62cc18ece0ebfed0ff6abf53d419d43d2fa1.tar.gz
FindPython*: Add capability to control virtual env handling.
Fixes: #19097
Diffstat (limited to 'Tests/FindPython/CMakeLists.txt')
-rw-r--r--Tests/FindPython/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/FindPython/CMakeLists.txt b/Tests/FindPython/CMakeLists.txt
index 38211a4bb5..d6f50e7b10 100644
--- a/Tests/FindPython/CMakeLists.txt
+++ b/Tests/FindPython/CMakeLists.txt
@@ -68,6 +68,17 @@ if(CMake_TEST_FindPython)
--build-options ${build_options}
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)
+
+ add_test(NAME FindPython.VirtualEnv COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindPython/VirtualEnv"
+ "${CMake_BINARY_DIR}/Tests/FindPython/VirtualEnv"
+ ${build_generator_args}
+ --build-project TestVirtualEnv
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )
endif()
if(CMake_TEST_FindPython_NumPy)