summaryrefslogtreecommitdiff
path: root/Tests/FindPython/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2020-10-29 17:02:55 +0100
committerMarc Chevrier <marc.chevrier@gmail.com>2020-11-03 15:12:58 +0100
commite452f6e2cf596c34e231b56803f739a878530ad9 (patch)
treef8f003d0d3e71c1b9288dacf513825c80ad64bb0 /Tests/FindPython/CMakeLists.txt
parent622ac065d2abeb53de3548b7e4f3d9b5980dfa8d (diff)
downloadcmake-e452f6e2cf596c34e231b56803f739a878530ad9.tar.gz
FindPython: Adds control over artifact names to search
Fixes: #21371
Diffstat (limited to 'Tests/FindPython/CMakeLists.txt')
-rw-r--r--Tests/FindPython/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/FindPython/CMakeLists.txt b/Tests/FindPython/CMakeLists.txt
index 44484c35ed..520ba9e166 100644
--- a/Tests/FindPython/CMakeLists.txt
+++ b/Tests/FindPython/CMakeLists.txt
@@ -451,6 +451,18 @@ if(CMake_TEST_FindPython)
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)
endif()
+
+ if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ add_test(NAME FindPython.UnversionedNames COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindPython/UnversionedNames"
+ "${CMake_BINARY_DIR}/Tests/FindPython/UnversionedNames"
+ ${build_generator_args}
+ --build-project UnversionedNames
+ --build-options ${build_options}
+ )
+ endif()
endif()
if(CMake_TEST_FindPython_NumPy)