summaryrefslogtreecommitdiff
path: root/Tests/InterfaceLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Lipponer <mail@sebastianlipponer.de>2019-01-14 19:46:59 +0100
committerSebastian Lipponer <mail@sebastianlipponer.de>2019-01-14 20:59:33 +0100
commit59c408d053cfe90273db04c3804ed91d7ad59d8f (patch)
treedabeb2526b6c1186d62d2574bdb73ac0f89a4e16 /Tests/InterfaceLibrary/CMakeLists.txt
parent4541c914b587125048c8e82bc3cd687f573f753a (diff)
downloadcmake-59c408d053cfe90273db04c3804ed91d7ad59d8f.tar.gz
cmTargetPropertyComputer: whitelist 'MANUALLY_ADDED_DEPENDENCIES'.
Diffstat (limited to 'Tests/InterfaceLibrary/CMakeLists.txt')
-rw-r--r--Tests/InterfaceLibrary/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/InterfaceLibrary/CMakeLists.txt b/Tests/InterfaceLibrary/CMakeLists.txt
index 3db210a5de..6aae09ac29 100644
--- a/Tests/InterfaceLibrary/CMakeLists.txt
+++ b/Tests/InterfaceLibrary/CMakeLists.txt
@@ -31,6 +31,7 @@ add_library(item_real STATIC item.cpp)
add_library(item_iface INTERFACE IMPORTED)
set_property(TARGET item_iface PROPERTY IMPORTED_LIBNAME item_real)
add_dependencies(item_iface item_real)
+get_property(item_iface_dependencies TARGET item_iface PROPERTY MANUALLY_ADDED_DEPENDENCIES)
link_directories(${CMAKE_CURRENT_BINARY_DIR})
add_executable(InterfaceLibrary definetestexe.cpp)