summaryrefslogtreecommitdiff
path: root/Tests/NewlineArgs/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2007-03-06 14:52:39 -0500
committerKen Martin <ken.martin@kitware.com>2007-03-06 14:52:39 -0500
commit820aa6b961a16af55959a870491b7521d39ff8ca (patch)
tree38fa079e4a41768a177736a3997a7723133b5cac /Tests/NewlineArgs/CMakeLists.txt
parent12b8643feec59a48f548ab02c574d79000b84e87 (diff)
downloadcmake-820aa6b961a16af55959a870491b7521d39ff8ca.tar.gz
ENH: added a tets for newlines in some commands
Diffstat (limited to 'Tests/NewlineArgs/CMakeLists.txt')
-rw-r--r--Tests/NewlineArgs/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/Tests/NewlineArgs/CMakeLists.txt b/Tests/NewlineArgs/CMakeLists.txt
new file mode 100644
index 0000000000..d58263917a
--- /dev/null
+++ b/Tests/NewlineArgs/CMakeLists.txt
@@ -0,0 +1,15 @@
+# a simple CXX only test case
+project (newlineargs CXX)
+
+add_definitions("-DTEST_FLAG_1
+-DTEST_FLAG_2")
+
+include_directories("${newlineargs_BINARY_DIR}
+${newlineargs_SOURCE_DIR}")
+
+configure_file("${newlineargs_SOURCE_DIR}/libcxx2.h.in"
+ "${newlineargs_BINARY_DIR}/libcxx2.h")
+
+add_library(testcxx1 libcxx1.cxx)
+add_executable (cxxonly cxxonly.cxx)
+target_link_libraries(cxxonly testcxx1)