summaryrefslogtreecommitdiff
path: root/Tests/ObjC/cxx-file-extension-test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-11-14 10:31:18 -0500
committerBrad King <brad.king@kitware.com>2019-11-14 10:57:42 -0500
commitd2e5e6ff1abec8b3b1579f122b7dcc89a35dbba4 (patch)
tree53e92d69536044321ac31d5543a6c426546b5aba /Tests/ObjC/cxx-file-extension-test/CMakeLists.txt
parent786954c4893565d8da27329201fd235e347e051d (diff)
downloadcmake-d2e5e6ff1abec8b3b1579f122b7dcc89a35dbba4.tar.gz
Tests: Organize Objective C/C++ test directories
Move them all under `Tests/ObjC` and `Tests/ObjCXX`.
Diffstat (limited to 'Tests/ObjC/cxx-file-extension-test/CMakeLists.txt')
-rw-r--r--Tests/ObjC/cxx-file-extension-test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/ObjC/cxx-file-extension-test/CMakeLists.txt b/Tests/ObjC/cxx-file-extension-test/CMakeLists.txt
new file mode 100644
index 0000000000..eb065e46d7
--- /dev/null
+++ b/Tests/ObjC/cxx-file-extension-test/CMakeLists.txt
@@ -0,0 +1,8 @@
+cmake_minimum_required(VERSION 3.15)
+
+project(cxx-file-extension-test)
+
+string(APPEND CMAKE_CXX_FLAGS " -std=c++11")
+set(CMAKE_CXX_STANDARD 14)
+
+add_executable(cxx-file-extension-test main.m)