summaryrefslogtreecommitdiff
path: root/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-07-16 13:26:56 -0400
committerAlexander Neundorf <neundorf@kde.org>2007-07-16 13:26:56 -0400
commitfac86048102011265b6a2f968f74618c63f96582 (patch)
treeaabe6a945f47897cd125204fedff1706bc651d46 /Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
parent5bb94ce16635954f460edcacd5422bc8d53fb8c1 (diff)
downloadcmake-fac86048102011265b6a2f968f74618c63f96582.tar.gz
BUG: GET_DIRECTORY_PROPERTY(INCLUDE_DIRECTORIES|LINK_DIRECTORIES) wasn't
working, for both the result was always empty, since cmMakefile::GetProperty() recognized it as a special property, constructed a correct return value and called cmMakefile::SetProperty() with this list of directories, which then didn't actually set the property, but applied it to the internal vector of include/link directories. The following getPropertyValue in cmMakefile::GetProperty() then still didn't find it and returned nothing. Now for all special property the static string output is used and its content is returned. I'm not sure it is the right way to fix this problem but at least it seems to work and it fixes the Paraview3 build Alex
Diffstat (limited to 'Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
index 175138bd54..b83991f353 100644
--- a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
+++ b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
@@ -46,3 +46,9 @@ ENDIF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
# test getting a definition from a subdir
SET (WEASELS SIZZLING)
+
+GET_DIRECTORY_PROPERTY(incDirs INCLUDE_DIRECTORIES)
+message(STATUS "incDirs: -${incDirs}")
+IF(NOT incDirs)
+ MESSAGE(FATAL_ERROR "GET_DIRECTORY_PROPERTY(INCLUDE_DIRECTORIES) returned empty list")
+ENDIF(NOT incDirs)