summaryrefslogtreecommitdiff
path: root/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2005-09-13 10:40:38 -0400
committerKen Martin <ken.martin@kitware.com>2005-09-13 10:40:38 -0400
commitfd26d148d8b71871bc5abe2f4e48b56d142d6be0 (patch)
tree3eeb7dd3ed158b669f0676efc3dea857585711b8 /Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
parent2a45d5cd684c835f6e97c28ef997ef5824f4827d (diff)
downloadcmake-fd26d148d8b71871bc5abe2f4e48b56d142d6be0.tar.gz
ENH: test get directory properties ability to get props from subdirs
Diffstat (limited to 'Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
index 412a1ca029..3180f28be6 100644
--- a/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
+++ b/Tests/OutOfSource/OutOfSourceSubdir/CMakeLists.txt
@@ -1,3 +1,5 @@
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
+
IF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
SET(BUILD_SHARED_LIBS 1)
ADD_LIBRARY(testlib testlib.cxx)
@@ -5,3 +7,5 @@ IF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
TARGET_LINK_LIBRARIES(simple testlib)
ENDIF ("${PROJECT_SOURCE_DIR}" STREQUAL "${ANOTHER_PROJ_SOURCE_DIR}")
+# test getting a definition from a subdir
+SET (WEASELS SIZZLING)