summaryrefslogtreecommitdiff
path: root/Tests/Qt6Autogen/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@crascit.com>2021-10-04 22:10:56 +1100
committerCraig Scott <craig.scott@crascit.com>2021-10-04 22:10:57 +1100
commita7420884723c4fb09e6370fb25710a2172c10a0c (patch)
tree7d1d5cd434ca27e8b038457c784bf08af7f36c2f /Tests/Qt6Autogen/CMakeLists.txt
parentb3a0bddc4e1c8f1f86078cdffaebbc4c493e4409 (diff)
downloadcmake-a7420884723c4fb09e6370fb25710a2172c10a0c.tar.gz
Tests: Add support for testing Qt6
The minimum CMake version for Qt6 is 3.16, so all the calls to cmake_minimum_required() are updated here to enforce that minimum. This will avoid any CMake version-related warnings from Qt. Avoid hard-coding Qt5 where the tests could now be using Qt5 or Qt6. Fixes: #22188
Diffstat (limited to 'Tests/Qt6Autogen/CMakeLists.txt')
-rw-r--r--Tests/Qt6Autogen/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/Qt6Autogen/CMakeLists.txt b/Tests/Qt6Autogen/CMakeLists.txt
new file mode 100644
index 0000000000..a603b50818
--- /dev/null
+++ b/Tests/Qt6Autogen/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Set Qt test version and include the Autogen test macros
+set(QT_TEST_VERSION 6)
+include("../QtAutogen/TestMacros.cmake")
+
+# Common tests
+include("../QtAutogen/Tests.cmake")
+
+set(TEST_BUILD_DIRS "${TEST_BUILD_DIRS}" PARENT_SCOPE)