summaryrefslogtreecommitdiff
path: root/Tests/RunCMake/CMP0064/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt McCormick <matt.mccormick@kitware.com>2014-12-29 20:47:48 -0500
committerBrad King <brad.king@kitware.com>2015-08-03 09:22:25 -0400
commit14e49ed15615e7f2bcb58aa4540683250006f5c7 (patch)
treefad463f1cb96d9da2ee65bee42e8e6a251aec971 /Tests/RunCMake/CMP0064/CMakeLists.txt
parent623dcc85a447b9ce0f09cffa8cd296cd8a51ad9d (diff)
downloadcmake-14e49ed15615e7f2bcb58aa4540683250006f5c7.tar.gz
if: Add "TEST <test>" condition
if(TEST TestNameThatExists) will return true if a test with the name TestNameThatExists has been added with add_test. The syntax is similar to if(TARGET TargetName). Since use of "TEST" as an argument to if() could previously be interpreted as a non-keyword argument, add policy CMP0064 to treat it as a keyword as NEW behavior.
Diffstat (limited to 'Tests/RunCMake/CMP0064/CMakeLists.txt')
-rw-r--r--Tests/RunCMake/CMP0064/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/RunCMake/CMP0064/CMakeLists.txt b/Tests/RunCMake/CMP0064/CMakeLists.txt
new file mode 100644
index 0000000000..74b3ff8de3
--- /dev/null
+++ b/Tests/RunCMake/CMP0064/CMakeLists.txt
@@ -0,0 +1,3 @@
+cmake_minimum_required(VERSION 3.3)
+project(${RunCMake_TEST} NONE)
+include(${RunCMake_TEST}.cmake)