summaryrefslogtreecommitdiff
path: root/Tests/SimpleInstallS2/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-03-03 18:44:32 -0500
committerBrad King <brad.king@kitware.com>2006-03-03 18:44:32 -0500
commita2e136fd17b693765a4961220433bdf207930583 (patch)
treeb785101e7a9fe7bed52a05e3d483216b500a4d70 /Tests/SimpleInstallS2/CMakeLists.txt
parent5792dc8da8a567ece9fd231e9844a5b1cd30ddc2 (diff)
downloadcmake-a2e136fd17b693765a4961220433bdf207930583.tar.gz
ENH: Added PERMISSIONS and RENAME options to the INSTALL command's FILES and PROGRAMS mode, and corresponding support to FILE(INSTALL). Default permissions for shared libraries on non-Windows/non-OSX platforms no longer has the execute bit set.
Diffstat (limited to 'Tests/SimpleInstallS2/CMakeLists.txt')
-rw-r--r--Tests/SimpleInstallS2/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/Tests/SimpleInstallS2/CMakeLists.txt b/Tests/SimpleInstallS2/CMakeLists.txt
index 14beef3035..fc5c861e33 100644
--- a/Tests/SimpleInstallS2/CMakeLists.txt
+++ b/Tests/SimpleInstallS2/CMakeLists.txt
@@ -58,7 +58,8 @@ IF(STAGE2)
PATHS ${LIBPATHS}
DOC "Fourth library")
- ADD_EXECUTABLE (SimpleInstallS2 inst.cxx foo.c foo.h)
+ INCLUDE_DIRECTORIES(${CMAKE_INSTALL_PREFIX}/include)
+ ADD_EXECUTABLE (SimpleInstallS2 inst2.cxx foo.c foo.h)
TARGET_LINK_LIBRARIES(SimpleInstallS2 ${TEST1_LIBRARY} ${TEST2_LIBRARY} ${TEST4_LIBRARY})
SET(install_target SimpleInstallS2)
@@ -93,7 +94,12 @@ ELSE(STAGE2)
INSTALL(TARGETS SimpleInstall test1 test2 test3 test4
RUNTIME DESTINATION bin LIBRARY DESTINATION lib)
- INSTALL(FILES lib1.h lib2.h DESTINATION include)
+ INSTALL(FILES lib1.h DESTINATION include/foo)
+ INSTALL(FILES lib2.h
+ DESTINATION include/foo
+ PERMISSIONS OWNER_READ OWNER_WRITE
+ RENAME lib2renamed.h
+ )
INSTALL_FILES(/include FILES lib3.h)
# Test user-specified install scripts.