summaryrefslogtreecommitdiff
path: root/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Pfeifer <daniel@pfeifer-mail.de>2012-09-06 12:31:47 +0200
committerBrad King <brad.king@kitware.com>2012-09-07 10:05:50 -0400
commit2f520d304a5cf874b22d978e9402e6d9316eb42e (patch)
tree172120cbf1a6ad3ccacda7e9ecfc500e3cf29df1 /Utilities/CMakeLists.txt
parent2da17ef7975b521abe2be4736569d19ef79dc3be (diff)
downloadcmake-2f520d304a5cf874b22d978e9402e6d9316eb42e.tar.gz
Simplify CMake.HTML documentation test command line
Drop the "cmake -E chdir" wrapper and instead pass the DTD directory to xmllint's --path option using url encoding. While at it, move the XHTML1 DTD to "Utilities/xml/xhtml1" to make room for additional DTDs.
Diffstat (limited to 'Utilities/CMakeLists.txt')
-rw-r--r--Utilities/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/Utilities/CMakeLists.txt b/Utilities/CMakeLists.txt
index 233d5e23a8..cb50eca21a 100644
--- a/Utilities/CMakeLists.txt
+++ b/Utilities/CMakeLists.txt
@@ -141,15 +141,15 @@ if(BUILD_TESTING)
execute_process(COMMAND ${LIBXML2_XMLLINT_EXECUTABLE} --help
OUTPUT_VARIABLE _help ERROR_VARIABLE _err)
if("${_help}" MATCHES "--path" AND "${_help}" MATCHES "--nonet")
- # We provide the XHTML DTD and its dependencies in the 'xml'
- # directory so that xmllint can run without network access.
- # However, it's --path option accepts a space-separated list of
- # paths so it cannot handle spaces in the path to the source tree.
- # Therefore we run the tool with the current work directory set to
- # the 'xml' directory and use '.' as the path.
+ # We provide DTDs in the 'xml' directory so that xmllint can run without
+ # network access. Note that xmllints's --path option accepts a
+ # space-separated list of url-encoded paths.
+ set(_dtd_dir "${CMAKE_CURRENT_SOURCE_DIR}/xml")
+ string(REPLACE " " "%20" _dtd_dir "${_dtd_dir}")
+ string(REPLACE ":" "%3A" _dtd_dir "${_dtd_dir}")
add_test(CMake.HTML
- ${CMAKE_CMAKE_COMMAND} -E chdir ${CMAKE_CURRENT_SOURCE_DIR}/xml
- ${LIBXML2_XMLLINT_EXECUTABLE} --valid --noout --nonet --path .
+ ${LIBXML2_XMLLINT_EXECUTABLE} --valid --noout --nonet
+ --path ${_dtd_dir}/xhtml1
${HTML_FILES}
)
endif()