summaryrefslogtreecommitdiff
path: root/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2010-11-04 10:07:11 -0400
committerDavid Cole <david.cole@kitware.com>2010-11-04 10:07:11 -0400
commit5d3cfdc1f8baf7485bfb89981c3a5eb550325bc3 (patch)
tree11f8af3a2183831ab6d1eb5604e16353625bd4ea /Utilities/CMakeLists.txt
parentbb1df1ec8ea880c9859845b85828b8b724abb1ba (diff)
downloadcmake-5d3cfdc1f8baf7485bfb89981c3a5eb550325bc3.tar.gz
No CMake.HTML test if xmllint has no --nonet.
In commit bb1df1ec, we temporarily ran an alternate test, guaranteed to fail when the --help output of xmllint did not contain --nonet and --path. This commit simply eliminates the test altogether in this condition rather than make an attempt (doomed to fail) to pull down the dtd over the internet. On date=2010-11-04, the CMake dashboard results showed that the test failed on the following CMake dashboard machines: dash8.kitware dash8.kitwarein.com dashsun1 dashsun1.kitware ferrari This is a very small subset of the dashboard machines, and we have enough proof from enough other machines that the test passes with xmllint versions new enough to have the --nonet support. Therefore, eliminate the CMake.HTML test on machines with old versions of xmllint. To run the test, make sure you run it on a machine with a new enough xmllint.
Diffstat (limited to 'Utilities/CMakeLists.txt')
-rw-r--r--Utilities/CMakeLists.txt28
1 files changed, 0 insertions, 28 deletions
diff --git a/Utilities/CMakeLists.txt b/Utilities/CMakeLists.txt
index e1c8827769..8b3e7f6589 100644
--- a/Utilities/CMakeLists.txt
+++ b/Utilities/CMakeLists.txt
@@ -152,34 +152,6 @@ if(BUILD_TESTING)
${LIBXML2_XMLLINT_EXECUTABLE} --valid --noout --nonet --path .
${HTML_FILES}
)
- else()
- # Intentionally committing this chunk of code for one night's run on the
- # Nightly dashboard suite. This will help us identify all machines with
- # older versions of xmllint installed. (This should match the set of
- # machines where this test is failing at the moment anyhow...)
- #
- # After we identify all of them, we can decide whether to simply make
- # this else block empty, skipping the test, or whether there should be
- # some alternative equivalent test on such machines...
- #
- set(script "${CMAKE_CURRENT_BINARY_DIR}/CMake.HTML.cmake")
-
- set(text "Intentionally fail when xmllint has no --nonet arg.")
- set(text "${text} The CMake test suite should avoid network activity")
- set(text "${text} when possible.")
-
- if(NOT EXISTS "${script}.in")
- file(WRITE "${script}.in" "execute_process(COMMAND
- \"${LIBXML2_XMLLINT_EXECUTABLE}\" OUTPUT_VARIABLE noargs)
-message(\"\${noargs}\")
-execute_process(COMMAND
- \"${LIBXML2_XMLLINT_EXECUTABLE}\" --version OUTPUT_VARIABLE version)
-message(\"\${version}\")
-message(FATAL_ERROR \"${text}\")
-")
- endif()
- configure_file("${script}.in" "${script}" @ONLY)
- add_test(CMake.HTML ${CMAKE_CMAKE_COMMAND} -P ${script})
endif()
endif()
endif()