summaryrefslogtreecommitdiff
path: root/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2008-05-13 15:43:00 -0400
committerAlexander Neundorf <neundorf@kde.org>2008-05-13 15:43:00 -0400
commit9a4e1c5cff84fd13c821b5c5d24b5e39d68b19e1 (patch)
tree3762898374692929411cfcdbc0e1c0871be9f2cc /Utilities/CMakeLists.txt
parent9eee4149ec6e2e69de52c81f7898c993eaa259f2 (diff)
downloadcmake-9a4e1c5cff84fd13c821b5c5d24b5e39d68b19e1.tar.gz
STYLE: add "--help-policy" and "--help-policies" to the documentation
-generate and install the policy documentation files -generate and install the docbook files for cmake, ctest, cpack, ccmake (cmake-gui not yet ?) Alex
Diffstat (limited to 'Utilities/CMakeLists.txt')
-rw-r--r--Utilities/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/Utilities/CMakeLists.txt b/Utilities/CMakeLists.txt
index 7cc35e41ff..5d75422b49 100644
--- a/Utilities/CMakeLists.txt
+++ b/Utilities/CMakeLists.txt
@@ -16,6 +16,7 @@ MACRO(ADD_DOCS target dependency)
ARGS --help-full ${CMake_BINARY_DIR}/Docs/${target}.txt
--help-full ${CMake_BINARY_DIR}/Docs/${target}.html
--help-full ${CMake_BINARY_DIR}/Docs/${target}.1
+ --help-full ${CMake_BINARY_DIR}/Docs/${target}.docbook
DEPENDS ${target}
MAIN_DEPENDENCY ${dependency}
)
@@ -23,6 +24,7 @@ MACRO(ADD_DOCS target dependency)
INSTALL_FILES(${CMAKE_DOC_DIR} FILES
${CMake_BINARY_DIR}/Docs/${target}.txt
${CMake_BINARY_DIR}/Docs/${target}.html
+ ${CMake_BINARY_DIR}/Docs/${target}.docbook
)
SET(DOC_FILES ${DOC_FILES} ${CMake_BINARY_DIR}/Docs/${target}.txt)
ENDIF(CMD)
@@ -44,6 +46,10 @@ ADD_CUSTOM_COMMAND(
--help-full ${CMake_BINARY_DIR}/Docs/cmake.txt
--help-full ${CMake_BINARY_DIR}/Docs/cmake.html
--help-full ${CMake_BINARY_DIR}/Docs/cmake.1
+ --help-full ${CMake_BINARY_DIR}/Docs/cmake.docbook
+ --help-policies ${CMake_BINARY_DIR}/Docs/cmake-policies.txt
+ --help-policies ${CMake_BINARY_DIR}/Docs/cmake-policies.html
+ --help-policies ${CMake_BINARY_DIR}/Docs/cmakepolicies.1
--help-properties ${CMake_BINARY_DIR}/Docs/cmake-properties.txt
--help-properties ${CMake_BINARY_DIR}/Docs/cmake-properties.html
--help-properties ${CMake_BINARY_DIR}/Docs/cmakeprops.1
@@ -68,17 +74,21 @@ INSTALL_FILES(${CMAKE_MAN_DIR}/man1 FILES
${CMake_BINARY_DIR}/Docs/cmakecommands.1
${CMake_BINARY_DIR}/Docs/cmakecompat.1
${CMake_BINARY_DIR}/Docs/cmakeprops.1
+ ${CMake_BINARY_DIR}/Docs/cmakepolicies.1
${CMake_BINARY_DIR}/Docs/cmakevars.1
${CMake_BINARY_DIR}/Docs/cmakemodules.1)
INSTALL_FILES(${CMAKE_DOC_DIR} FILES
${CMake_BINARY_DIR}/Docs/cmake.txt
${CMake_BINARY_DIR}/Docs/cmake.html
+ ${CMake_BINARY_DIR}/Docs/cmake.docbook
+ ${CMake_BINARY_DIR}/Docs/cmake-policies.txt
+ ${CMake_BINARY_DIR}/Docs/cmake-policies.html
${CMake_BINARY_DIR}/Docs/cmake-properties.txt
${CMake_BINARY_DIR}/Docs/cmake-properties.html
${CMake_BINARY_DIR}/Docs/cmake-variables.txt
${CMake_BINARY_DIR}/Docs/cmake-variables.html
- ${CMake_BINARY_DIR}/Docs/cmake-modules.txt
+ ${CMake_BINARY_DIR}/Docs/cmake-modules.txt
${CMake_BINARY_DIR}/Docs/cmake-modules.html
${CMake_BINARY_DIR}/Docs/cmake-commands.txt
${CMake_BINARY_DIR}/Docs/cmake-commands.html