summaryrefslogtreecommitdiff
path: root/Utilities/CMakeLists.txt
diff options
context:
space:
mode:
authorNils Gladitz <nilsgladitz@gmail.com>2016-02-07 20:25:56 +0100
committerBrad King <brad.king@kitware.com>2016-02-09 10:28:57 -0500
commita12b0f1b193024b71583b9150aeead33d364d189 (patch)
treef94b0230c6bfdb8e72b1572877fcadcb0d6d2a72 /Utilities/CMakeLists.txt
parenta5a5a6857241c21d306661d723b749839f4c6e1a (diff)
downloadcmake-a12b0f1b193024b71583b9150aeead33d364d189.tar.gz
CMake: Prevent WiX installations over existing NSIS installations
Use a custom action to look for Uninstall.exe in the user selected installation prefix. Its presence indicates a previous NSIS installation. Inform the user and request manual resolution of the issue.
Diffstat (limited to 'Utilities/CMakeLists.txt')
-rw-r--r--Utilities/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Utilities/CMakeLists.txt b/Utilities/CMakeLists.txt
index 8b3e325fa0..cf6bb72852 100644
--- a/Utilities/CMakeLists.txt
+++ b/Utilities/CMakeLists.txt
@@ -33,3 +33,7 @@ else()
# Normal documentation build.
add_subdirectory(Sphinx)
endif()
+
+if(WIX_CUSTOM_ACTION_ENABLED)
+ add_subdirectory(Release/WiX)
+endif()