summaryrefslogtreecommitdiff
path: root/Utilities/cmlibarchive/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-08-26 11:50:08 -0400
committerBrad King <brad.king@kitware.com>2013-08-26 11:54:07 -0400
commitdf62f64db72b6f00657e9e739e1e117639dea9da (patch)
tree88a64dd1f0579ab27b18b0911c817c1e556b3259 /Utilities/cmlibarchive/CMakeLists.txt
parent8da09f6ee1a59cbef6327d2a88ab8ba5f8b29b1a (diff)
downloadcmake-df62f64db72b6f00657e9e739e1e117639dea9da.tar.gz
Clean up install rules of CMake itself (#14371)
Ensure CMAKE_DATA_DIR, CMAKE_DOC_DIR, and CMAKE_MAN_DIR are always relative paths in CMake code, and set defaults accordingly. Use the install() command instead of install_files() and install_targets(). This is more modern and also avoids stripping of the first character from user-specified destinations. While at it, fix the default destinations reported in the bootstrap help.
Diffstat (limited to 'Utilities/cmlibarchive/CMakeLists.txt')
-rw-r--r--Utilities/cmlibarchive/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Utilities/cmlibarchive/CMakeLists.txt b/Utilities/cmlibarchive/CMakeLists.txt
index 621888c34c..8ef0e89d6d 100644
--- a/Utilities/cmlibarchive/CMakeLists.txt
+++ b/Utilities/cmlibarchive/CMakeLists.txt
@@ -1311,4 +1311,4 @@ ENDIF(APPLE)
add_subdirectory(libarchive)
-install(FILES COPYING DESTINATION ${CMake_DOC_DEST}/cmlibarchive)
+install(FILES COPYING DESTINATION ${CMAKE_DOC_DIR}/cmlibarchive)