summaryrefslogtreecommitdiff
path: root/Utilities/cmzlib/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2007-09-11 11:22:29 -0400
committerDavid Cole <david.cole@kitware.com>2007-09-11 11:22:29 -0400
commit3edcd70754afe7c6b2ff71e0010c6b3d64b4fe37 (patch)
tree0dca962765d94496432c628b96dbfeef7a252064 /Utilities/cmzlib/CMakeLists.txt
parentf262298bb037b683c995f239d1ca9fc00aaec3f3 (diff)
downloadcmake-3edcd70754afe7c6b2ff71e0010c6b3d64b4fe37.tar.gz
ENH: Update zlib to 1.2.3. Addresses bugs #5445 and #3473.
Diffstat (limited to 'Utilities/cmzlib/CMakeLists.txt')
-rw-r--r--Utilities/cmzlib/CMakeLists.txt18
1 files changed, 3 insertions, 15 deletions
diff --git a/Utilities/cmzlib/CMakeLists.txt b/Utilities/cmzlib/CMakeLists.txt
index f359082ccd..fdbd9ed796 100644
--- a/Utilities/cmzlib/CMakeLists.txt
+++ b/Utilities/cmzlib/CMakeLists.txt
@@ -6,29 +6,17 @@ INCLUDE_DIRECTORIES(
"${CMZLIB_BINARY_DIR}/.."
)
-# Tell the header files included from the .c files that they are being
-# built. Used to disable warnings since we do not want to change the
-# code much.
-ADD_DEFINITIONS(-DCMZLIB_IN_C)
-
# Match all headers for dependencies but complain about none.
INCLUDE_REGULAR_EXPRESSION("^.*$")
-# Disable warnings on Borland to avoid changing 3rd party code.
-IF(BORLAND)
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -w-")
-ENDIF(BORLAND)
-
# source files for zlib
SET(ZLIB_SRCS
- adler32.c gzio.c inftrees.c uncompr.c
- compress.c infblock.c infutil.c zutil.c
- crc32.c infcodes.c
- deflate.c inffast.c
- inflate.c trees.c
+ adler32.c compress.c crc32.c deflate.c gzio.c inffast.c
+ inflate.c inftrees.c trees.c uncompr.c zutil.c
)
# for windows add the .def and .rc files to the source list
+# if building shared libs
IF(WIN32)
IF(BUILD_SHARED_LIBS)
SET(ZLIB_DLL 1)