summaryrefslogtreecommitdiff
path: root/Utilities/std/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2019-08-04 10:49:16 +0200
committerBrad King <brad.king@kitware.com>2019-09-20 10:01:37 -0400
commitc688b401d3adaacc820ef4b589010e8aefa808b1 (patch)
tree83e46e3dc7c9847692e61d0e6629b1cf9b65d2a5 /Utilities/std/CMakeLists.txt
parent9c31d83aa2a3d3f5921f4a5a559e126e285b96c5 (diff)
downloadcmake-c688b401d3adaacc820ef4b589010e8aefa808b1.tar.gz
cmstd: Modernize CMake system headers
Provide a standardized way to handle the C++ "standard" headers customized to be used with current CMake C++ standard constraints. Offer under directory `cm` headers which can be used as direct replacements of the standard ones. For example: #include <cm/string_view> can be used safely for CMake development in place of the `<string_view>` standard header. Fixes: #19491
Diffstat (limited to 'Utilities/std/CMakeLists.txt')
-rw-r--r--Utilities/std/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Utilities/std/CMakeLists.txt b/Utilities/std/CMakeLists.txt
new file mode 100644
index 0000000000..63c0a60eae
--- /dev/null
+++ b/Utilities/std/CMakeLists.txt
@@ -0,0 +1,10 @@
+
+# source files for CMake std library
+set(SRCS cm/bits/string_view.cxx
+ cm/memory
+ cm/optional
+ cm/shared_mutex
+ cm/string_view
+ cm/utility)
+
+add_library(cmstd STATIC ${SRCS})