summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-27 14:35:34 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-27 14:35:34 -0400
commit8d80a9055e0417328c7bb326eab228cb7819d46b (patch)
tree9588a2a32a8cb6e1c9abdfdee6af56408d382af0 /configure.in
parent3b5ce4b88a072fac9298ea599e99ecd9cf973804 (diff)
downloadcmake-8d80a9055e0417328c7bb326eab228cb7819d46b.tar.gz
ENH: clean up sgi build and use non-broken autoconf
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6a4099a2be..77546fb297 100644
--- a/configure.in
+++ b/configure.in
@@ -41,6 +41,7 @@ else
fi
CMAKE_ANSI_CFLAGS=""
+CMAKE_ANSI_CXXFLAGS=""
# on hp use -Aa for ansi
if test $ac_cv_prog_gxx = no; then
case $system in
@@ -60,7 +61,7 @@ case $system in
echo 'void f(){}' > conftest.c
if test -z "`${CC} -LANG:std -c conftest.c 2>&1`"; then
echo "$ac_t""yes" 1>&6
- CMAKE_ANSI_CFLAGS="-LANG:std"
+ CMAKE_ANSI_CXXFLAGS="-LANG:std"
else
echo "$ac_t""no" 1>&6
fi
@@ -69,6 +70,7 @@ case $system in
esac
fi
AC_SUBST(CMAKE_ANSI_CFLAGS)
+AC_SUBST(CMAKE_ANSI_CXXFLAGS)
# if we are not running g++ then we might need some other flags
# to get the templates compiled correctly