summaryrefslogtreecommitdiff
path: root/Tests/FindX11/Test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/FindX11/Test/CMakeLists.txt')
-rw-r--r--Tests/FindX11/Test/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/Tests/FindX11/Test/CMakeLists.txt b/Tests/FindX11/Test/CMakeLists.txt
index afc10c9a5d..3312f6f772 100644
--- a/Tests/FindX11/Test/CMakeLists.txt
+++ b/Tests/FindX11/Test/CMakeLists.txt
@@ -11,14 +11,8 @@ function (test_x11_component have_var component)
endif ()
add_executable(test_tgt_${component} main.c)
-
- if (component MATCHES xcb)
- target_link_libraries(test_tgt_${component} PRIVATE X11::${component} X11::xcb)
- target_compile_definitions(test_tgt_${component} PRIVATE HAVE_X11_${component} HAVE_X11_xcb)
- else()
- target_link_libraries(test_tgt_${component} PRIVATE X11::${component})
- target_compile_definitions(test_tgt_${component} PRIVATE HAVE_X11_${component})
- endif()
+ target_link_libraries(test_tgt_${component} PRIVATE X11::${component})
+ target_compile_definitions(test_tgt_${component} PRIVATE HAVE_X11_${component})
add_test(NAME test_tgt_${component} COMMAND test_tgt_${component})
# Add to the list of components to test for the parent.