summaryrefslogtreecommitdiff
path: root/Tests/ForceInclude/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/ForceInclude/CMakeLists.txt')
-rw-r--r--Tests/ForceInclude/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/ForceInclude/CMakeLists.txt b/Tests/ForceInclude/CMakeLists.txt
index 5c02ebbd09..e2310543d9 100644
--- a/Tests/ForceInclude/CMakeLists.txt
+++ b/Tests/ForceInclude/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.8.3.20110103)
project(ForceInclude C)
# Make sure the proper compiler is in use.
-if(NOT MSVC AND NOT "${CMAKE_C_COMPILER_ID}" MATCHES "^(Intel)$")
+if(NOT MSVC AND NOT CMAKE_C_COMPILER_ID STREQUAL "Intel")
message(FATAL_ERROR "The ForceInclude test works only with MSVC or Intel")
endif()