summaryrefslogtreecommitdiff
path: root/Utilities/Doxygen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Utilities/Doxygen/CMakeLists.txt')
-rw-r--r--Utilities/Doxygen/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/Utilities/Doxygen/CMakeLists.txt b/Utilities/Doxygen/CMakeLists.txt
new file mode 100644
index 0000000000..f17215b0bb
--- /dev/null
+++ b/Utilities/Doxygen/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Build the documentation
+#
+INCLUDE (${CMAKE_ROOT}/Modules/DocumentationVTK.cmake OPTIONAL)
+
+IF (BUILD_DOCUMENTATION)
+
+ #
+ # Configure the script and the doxyfile, then add target
+ #
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/Utilities/Doxygen/doxyfile.in
+ ${CMAKE_BINARY_DIR}/Utilities/Doxygen/doxyfile)
+
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/Utilities/Doxygen/doc_makeall.sh.in
+ ${CMAKE_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ ADD_CUSTOM_TARGET(DoxygenDoc
+ ${BASH}
+ ${CMAKE_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ENDIF (BUILD_DOCUMENTATION)