summaryrefslogtreecommitdiff
path: root/Utilities/cmjsoncpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Utilities/cmjsoncpp/CMakeLists.txt')
-rw-r--r--Utilities/cmjsoncpp/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Utilities/cmjsoncpp/CMakeLists.txt b/Utilities/cmjsoncpp/CMakeLists.txt
index 0ff8820f4b..1c863f8557 100644
--- a/Utilities/cmjsoncpp/CMakeLists.txt
+++ b/Utilities/cmjsoncpp/CMakeLists.txt
@@ -1,5 +1,13 @@
project(JsonCpp CXX)
+# Disable warnings to avoid changing 3rd party code.
+if(CMAKE_CXX_COMPILER_ID MATCHES
+ "^(GNU|Clang|AppleClang|XL|VisualAge|SunPro|MIPSpro|HP|Intel)$")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -w")
+elseif(CMAKE_CXX_COMPILER_ID STREQUAL "PathScale")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -woffall")
+endif()
+
set(JSONCPP_SOURCES
src/lib_json/json_batchallocator.h
src/lib_json/json_reader.cpp