summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2018-01-27 11:39:02 +0300
committerKonstantin Podsvirov <konstantin@podsvirov.pro>2018-01-29 18:24:10 +0300
commit108de08b4283b7cbc522e4de9604d785349bad03 (patch)
tree3db0841212120b32eb0baf919cab6155ab4c5d6e /CMakeLists.txt
parent1a25592250954f460a811805f5537d7d1198294b (diff)
downloadcolm-108de08b4283b7cbc522e4de9604d785349bad03.tar.gz
Add CMake project
Now implemented: - Bootstrap `colm` program from sources; - Install target `colm::coml` and `colm::libcolm` via CMake's `colm` package. Shadow build support via CMake. Tested with MSYS2 and MinGW-w64 on Windows and with GCC on Linux. Detected issue when sizeof(word_t) < sizeof(void*).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..89bc5c68
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.0)
+
+project(colm
+ VERSION 0.13.0.5
+ LANGUAGES C CXX)
+set(PROJECT_PUBDATE "May 2017")
+
+set(${PROJECT_NAME}_MAKE_INSTALL ON CACHE BOOL
+ "Set to OFF to disable install rules (default is ON)")
+
+add_subdirectory(src)