summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2011-05-11 18:47:31 +0000
committerAdrian Thurston <thurston@complang.org>2011-05-11 18:47:31 +0000
commitf22a5b633b9492a3b8ad03286feea090bd32513d (patch)
treea068d814caffcf6bdecc5b73a525f9ed229957d0 /Makefile.am
parente2d471562ef5e0488c17fe8a874bb6d6f32c7bfe (diff)
downloadcolm-f22a5b633b9492a3b8ad03286feea090bd32513d.tar.gz
Started converting build to automake. refs #284.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am95
1 files changed, 95 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..feb2f16e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,95 @@
+#
+# Copyright 2001-2007 Adrian Thurston <thurston@complang.org>
+#
+
+# This file is part of Colm.
+#
+# Colm is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# Colm is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Colm; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+
+# ADT BUILD_SUBDIRS = colm
+# ADT ALL_SUBDIRS = $(BUILD_SUBDIRS) test
+# ADT
+# ADT #*************************************
+# ADT
+# ADT # Programs
+# ADT CXX = @CXX@
+# ADT
+# ADT # Get the version info.
+# ADT include version.mk
+# ADT
+# ADT # build targets
+# ADT all: $(BUILD_SUBDIRS)
+# ADT
+# ADT .PHONY: $(BUILD_SUBDIRS)
+# ADT
+# ADT $(BUILD_SUBDIRS):
+# ADT @cd $@ && $(MAKE)
+# ADT
+# ADT # clean targets.
+# ADT
+# ADT CLEAN_SUBDIRS = $(ALL_SUBDIRS:%=%-clean)
+# ADT
+# ADT .PHONY: $(CLEAN_SUBDIRS)
+# ADT
+# ADT $(CLEAN_SUBDIRS):
+# ADT @cd $(@:%-clean=%) && $(MAKE) clean
+# ADT
+# ADT clean: $(CLEAN_SUBDIRS)
+# ADT rm -f tags
+# ADT
+# ADT # distcleaan targets
+# ADT
+# ADT DISTCLEAN_SUBDIRS = $(ALL_SUBDIRS:%=%-distclean)
+# ADT
+# ADT .PHONY: $(DISTCLEAN_SUBDIRS)
+# ADT
+# ADT $(DISTCLEAN_SUBDIRS):
+# ADT @cd $(@:%-distclean=%) && $(MAKE) clean
+# ADT
+# ADT distclean: $(DISTCLEAN_SUBDIRS)
+# ADT rm -f Makefile config.cache config.status config.log
+# ADT
+# ADT #install targets
+# ADT
+# ADT INSTALL_SUBDIRS = $(BUILD_SUBDIRS:%=%-install)
+# ADT
+# ADT .PHONY: $(INSTALL_SUBDIRS)
+# ADT
+# ADT $(INSTALL_SUBDIRS):
+# ADT @cd $(@:%-install=%) && $(MAKE) install
+# ADT
+# ADT install: $(INSTALL_SUBDIRS)
+# ADT
+
+
+SUBDIRS = colm
+DIST_SUBDIRS = $(SUBDIRS) aapl test
+
+#dist_doc_DATA = CREDITS ChangeLog
+#EXTRA_DIST = ragel.vim
+
+# This file is checked for by the configure script and its existence causes the
+# parsers and the manual to not be built when the distribution is built.
+dist-hook:
+ ( \
+ echo "#!/bin/sh"; \
+ echo ""; \
+ echo "# Change to yes to enable building of parsers or manual. Reconfigure"; \
+ echo "# afterwards."; \
+ echo "build_parsers=no;"; \
+ echo "build_manual=no;"; \
+ ) > $(distdir)/DIST
+