summaryrefslogtreecommitdiff
path: root/colm/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2011-07-28 02:19:59 +0000
committerAdrian Thurston <thurston@complang.org>2011-07-28 02:19:59 +0000
commit6a78200a3d72a12bd0e16a9350fd0eaafa15b548 (patch)
tree44391faa9656f4eec62757576f84eb654d5dab20 /colm/Makefile.am
parentf8bd8a207022503a6628a2cdd2c8b7a9a64792fb (diff)
downloadcolm-6a78200a3d72a12bd0e16a9350fd0eaafa15b548.tar.gz
Pointer and Ref type references needed work following the recent improvements
to the type system. Rather than use a bool in typeref, wrap them in a whole typeref. refs #308. Added the analysis.cc file and moved the top-level compilation calls there. Moved a few function calls around to fix some crashes observed during testing. Have to be concerned about type resolution in productions that are created during type resolution (repeats, etc).
Diffstat (limited to 'colm/Makefile.am')
-rw-r--r--colm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/colm/Makefile.am b/colm/Makefile.am
index 6b0f6dbf..f29d4f66 100644
--- a/colm/Makefile.am
+++ b/colm/Makefile.am
@@ -165,7 +165,7 @@ colm_SOURCES = \
parsedata.cc fsmstate.cc fsmbase.cc fsmattach.cc fsmmin.cc \
fsmgraph.cc pdagraph.cc pdabuild.cc pdacodegen.cc fsmcodegen.cc \
redfsm.cc fsmexec.cc main.cc redbuild.cc closure.cc fsmap.cc \
- dotgen.cc pcheck.cc ctinput.cc declare.cc
+ dotgen.cc pcheck.cc ctinput.cc declare.cc analysis.cc
colmincdir = $(includedir)/colm